[ GLSA 200904-02 ] GLib: Execution of arbitrary code

From: Robert Buchholz <rbu@gentoo.org>
To: gentoo-announce@gentoo.org
Cc: bugtraq@securityfocus.com,full-disclosure@lists.grok.org.uk,security-alerts@linuxsecurity.com
Subject: [ GLSA 200904-02 ] GLib: Execution of arbitrary code
Date:


- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200904-02
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: GLib: Execution of arbitrary code
      Date: April 03, 2009
      Bugs: #249214
        ID: 200904-02

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple integer overflows might allow for the execution of arbitrary
code when performing base64 conversion.

Background
==========

The GLib is a library of C routines that is used by a multitude of
programs.

Affected packages
=================

    -------------------------------------------------------------------
     Package        /   Vulnerable   /                      Unaffected
    -------------------------------------------------------------------
  1  dev-libs/glib      < 2.18.4-r1                       >= 2.18.4-r1
                                                         *>= 2.16.6-r1

Description
===========

Diego E. Petten reported multiple integer overflows in glib/gbase64.c
when converting a long string from or to a base64 representation.

Impact
======

A remote attacker could entice a user or automated system to perform a
base64 conversion via an application using GLib, possibly resulting in
the execution of arbitrary code.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All GLib 2.18 users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-libs/glib-2.18.4-r1"

All GLib 2.16 users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-libs/glib-2.16.6-r1"

References
==========

  [ 1 ] CVE-2008-4316
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-4316

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200904-02.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2009 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5




Copyright © 1995-2019 LinuxRocket.net. All rights reserved.