[ GLSA 200808-06 ] libxslt: Execution of arbitrary code

From: Tobias Heinlein <keytoaster@gentoo.org>
To: gentoo-announce@gentoo.org
Cc: bugtraq@securityfocus.com,full-disclosure@lists.grok.org.uk,security-alerts@linuxsecurity.com
Subject: [ GLSA 200808-06 ] libxslt: Execution of arbitrary code
Date:


- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200808-06
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: libxslt: Execution of arbitrary code
      Date: August 06, 2008
      Bugs: #232172
        ID: 200808-06

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

libxslt is affected by a heap-based buffer overflow, possibly leading
to the execution of arbitrary code.

Background
==========

libxslt is the XSLT C library developed for the GNOME project. XSLT is
an XML language to define transformations for XML.

Affected packages
=================

    -------------------------------------------------------------------
     Package           /   Vulnerable   /                   Unaffected
    -------------------------------------------------------------------
  1  dev-libs/libxslt      < 1.1.24-r1                    >= 1.1.24-r1
                                                               < 1.1.8

Description
===========

Chris Evans (Google Security) reported that the libexslt library that
is part of libxslt is affected by a heap-based buffer overflow in the
RC4 encryption/decryption functions.

Impact
======

A remote attacker could entice a user to process an XML file using a
specially crafted XSLT stylesheet in an application linked against
libxslt, possibly leading to the execution of arbitrary code with the
privileges of the user running the application.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All libxslt users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-libs/libxslt-1.1.24-r1"

References
==========

  [ 1 ] CVE-2008-2935
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-2935

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200808-06.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2008 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5





Copyright © 1995-2021 LinuxRocket.net. All rights reserved.