HTB22858: SQL Injection in WP Forum wordpress plugin

From: advisory@htbridge.ch
To: bugtraq@securityfocus.com
Cc:
Subject: HTB22858: SQL Injection in WP Forum wordpress plugin
Date:


Vulnerability ID: HTB22858
Reference: http://www.htbridge.ch/advisory/sql_injection_in_wp_forum_wordpress_plugin.html
Product: WP Forum wordpress plugin
Vendor: Fredrik Fahlstad ( http://www.fahlstad.se/ ) 
Vulnerable Version: 1.7.8
Vendor Notification: 15 February 2011 
Vulnerability Type: SQL Injection
Risk level: High 
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/) 

Vulnerability Details:
The vulnerability exists due to failure in the "/wp-content/plugins/wpforum/forum_feed.php" script to properly sanitize user-supplied input in "thread" variable.
Attacker can alter queries to the application SQL database, execute arbitrary queries to the database, compromise the application, access or modify sensitive data, or exploit various vulnerabilities in the underlying SQL database.

The following PoC is available:


http://[host]/wp-content/plugins/wpforum/forum_feed.php?thread=SQL_CODE_HERE







Copyright © 1995-2018 LinuxRocket.net. All rights reserved.