Re: Fwd: vulnerability issue for DB2 express

From: shatter@appsecinc.com
To: bugtraq@securityfocus.com
Cc:
Subject: Re: Fwd: vulnerability issue for DB2 express
Date:


This was a bug in the DB2 code and was fixed by IBM long ago.
Both, v6 and v7 of DB2 are very old and out of support versions. Even if you apply the Fix Packs mentioned below you will still have many other security vulnerabilities in the system.
My recommendation is to plan on upgrading the DB2 server to a newer version of DB2 that is still supported by IBM.

For DB2 version 6.1, this was fixed in FixPak 8. You can download this FixPak from 
ftp://ftp.software.ibm.com/ps/products/db2/fixes/english-us

For DB2 version 7.x, this was fixed in FixPak 3. This FixPak can be downloaded from 
http://www-306.ibm.com/software/data/db2/udb/support/downloadv7.html

You can also find some more information here:
http://www.teamshatter.com/threat-finder/519-ibm-db2-datevarchar-dos/





Copyright © 1995-2020 LinuxRocket.net. All rights reserved.