[ GLSA 200712-09 ] Ruby-GNOME2: Format string error

From: Pierre-Yves Rofes <py@gentoo.org>
To: gentoo-announce@gentoo.org
Cc: full-disclosure@lists.grok.org.uk,bugtraq@securityfocus.com,security-alerts@linuxsecurity.com
Subject: [ GLSA 200712-09 ] Ruby-GNOME2: Format string error
Date:


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200712-09
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Ruby-GNOME2: Format string error
      Date: December 09, 2007
      Bugs: #200623
        ID: 200712-09

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A format string error has been discovered in Ruby-GNOME2, possibly
leading to the execution of arbitrary code.

Background
==========

Ruby-GNOME2 is a set of bindings for using GTK+ within the Ruby
programming language.

Affected packages
=================

    -------------------------------------------------------------------
     Package             /   Vulnerable   /                 Unaffected
    -------------------------------------------------------------------
  1  dev-ruby/ruby-gtk2      < 0.16.0-r2                  >= 0.16.0-r2

Description
===========

Chris Rohlf discovered that the "Gtk::MessageDialog.new()" method in
the file gtk/src/rbgtkmessagedialog.c does not properly sanitize the
"message" parameter before passing it to the gtk_message_dialog_new()
function.

Impact
======

A remote attacker could send a specially crafted string to an
application using Ruby-GNOME2, possibly leading to the execution of
arbitrary code with the privileges of the user running the application.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Ruby-GNOME2 users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-ruby/ruby-gtk2-0.16.0-r2"

References
==========

  [ 1 ] CVE-2007-6183
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-6183

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200712-09.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2007 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFHXGmDuhJ+ozIKI5gRAmOYAJsEmqn17bS+DHxC0fcXtVLgGx7nIgCdGsX5
9F1zMj/LV9WlVMtWcmi7JCQ=
=XgO7
-----END PGP SIGNATURE-----





Copyright © 1995-2019 LinuxRocket.net. All rights reserved.