PR06-09: BEA Plumtree portal full version disclosure vulnerability

From: research@procheckup.com
To: bugtraq@securityfocus.com
Cc:
Subject: PR06-09: BEA Plumtree portal full version disclosure vulnerability
Date:


PR06-09: BEA Plumtree portal full version disclosure vulnerability

Description:

BEA Plumtree portal 6.0 is vulnerable to a full version disclosure vulnerability.

The exact version along with the build date is always included at the bottom of every requested HTML page within HTML comments.

Date Found: 12th September 2006

Vendor contacted: 18th May 2007

Vulnerable: BEA Plumtree 5.0.2, 5.0.3, 5.0.4, 6.0.1.218452 and possibly other versions.

Severity: Low

Authors: Adrian Pastor and Jan Fry of ProCheckUp Ltd (www.procheckup.com)

ProCheckUp thanks BEA for working with us.

Proof of concept:

The following is an example of full version information and build date disclosed within HTML comments:

<!--Portal Version: 6.0.1.218452, Changelist: 218452, Build Date: 04/07/2006 at 10:13 AM-->

Consequences:

Attackers can use specific version information in order to launch exploits that work on the enumerated version. This allows attackers to narrow down the number of exploits that might work  against the target.

Fix:

This has been addressed in AquaLogic Interaction 6.1. MP1. This can also be addressed by making config changes in ALUI 6.x versions.

References:

http://www.procheckup.com/Vulnerability_2007.php
http://dev2dev.bea.com/pub/advisory/252
http://www.plumtree.com/





Copyright © 1995-2020 LinuxRocket.net. All rights reserved.