Elasticsearch vulnerability CVE-2015-3337

From: Kevin Kluge <kevin@elastic.co>
To: bugtraq@securityfocus.com
Cc:
Subject: Elasticsearch vulnerability CVE-2015-3337
Date:


Summary:
All Elasticsearch versions prior to 1.5.2 and 1.4.5 are vulnerable to a directory traversal attack that allows an attacker to retrieve files from the server running  Elasticsearch.  This vulnerability is not present in the initial installation of Elasticsearch.  The vulnerability is exposed when a \u20ac\u0153site plugin\u20ac is installed.  Elastic\u20ac\u2122s Marvel plugin and many community-sponsored plugins (e.g. Kopf, BigDesk, Head) are site plugins.  Elastic Shield, Licensing, Cloud-AWS, Cloud-GCE, Cloud-Azure, the analysis plugins, and the river plugins are not site plugins.

We have been assigned CVE-2015-3337 for this issue.


Fixed versions:
Versions 1.5.2 and 1.4.5 have addressed the vulnerability.


Remediation:
Users should upgrade to 1.5.2 or 1.4.5.  This will address the vulnerability and preserve site plugin functionality.

Users that do not want to upgrade can address the vulnerability in several ways, but these options will break any site plugin:
- Set \u20ac\u0153http.disable_sites\u20ac to true and restart the Elasticsearch node.
- Use a firewall or proxy to block HTTP requests to /_plugin.
- Uninstall all site plugins from all Elasticsearch nodes.


Credit:
John Heasman of DocuSign reported this issue.


CVSS
Overall CVSS score: 4.3






Copyright © 1995-2018 LinuxRocket.net. All rights reserved.