CVE-2016-6811: Apache Hadoop Privilege escalation vulnerability

From: Akira Ajisaka <aajisaka@apache.org>
To: general@hadoop.apache.org,user@hadoop.apache.org,<security@hadoop.apache.org> <security@hadoop.apache.org>,bugtraq@securityfocus.com,oss-security@lists.openwall.com
Cc:
Subject: CVE-2016-6811: Apache Hadoop Privilege escalation vulnerability
Date:


CVE-2016-6811: Apache Hadoop Privilege escalation vulnerability

Severity: Critical

Vendor: The Apache Software Foundation

Versions Affected:
All the Apache Hadoop versions from 2.2.0 to 2.7.3

Description:
A user who can escalate to yarn user can possibly run arbitrary commands as root user.

Mitigation:
Users should upgrade to 2.7.4 or upper.
If you are using the affected version of Apache Hadoop and there are
any users who can escalate to yarn user and cannot escalate to root user,
remove the permission to escalate to yarn user from them.

Credit:
This issue was discovered by Freddie Rice.





Copyright © 1995-2018 LinuxRocket.net. All rights reserved.