Re: Re: Re: Re: Re: Gadu-Gadu Local/Remote Buffer Overflow- vulnerability

From: gynvael@vexillium.org
To: bugtraq@securityfocus.com
Cc:
Subject: Re: Re: Re: Re: Re: Gadu-Gadu Local/Remote Buffer Overflow- vulnerability
Date:


I think you are still missing the point. Don't look at the bug like a bug in a text file, but rather than as a bug in emoticons. Since Gadu-Gadu users do download whole emoticons sets and use them (for example from http://www.emoty.com.pl/download,gadu-gadu,emoty,01.htm sorry, it's in polish).
Please imagine a situation when one of the emoticons sets on the website has a malformed emots.txt. The user does not see the Text file, the user sees an emoticons set. He will extract it and the exploit will execute.
So we are talking about 'a emoticon sets' being an emoticons set, and not about text file being a configuration file.

Well, at least that is my point of view ;>
Best regards and thanks for your e-mail,





Copyright © 1995-2020 LinuxRocket.net. All rights reserved.