[ GLSA 200805-02 ] phpMyAdmin: Information disclosure

From: Pierre-Yves Rofes <py@gentoo.org>
To: gentoo-announce@gentoo.org
Cc: full-disclosure@lists.grok.org.uk,bugtraq@securityfocus.com,security-alerts@linuxsecurity.com
Subject: [ GLSA 200805-02 ] phpMyAdmin: Information disclosure
Date:


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200805-02
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Low
     Title: phpMyAdmin: Information disclosure
      Date: May 05, 2008
      Bugs: #219005
        ID: 200805-02

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in phpMyAdmin may lead to information disclosure.

Background
==========

phpMyAdmin is a tool written in PHP intended to handle the
administration of MySQL databases from a web-browser.

Affected packages
=================

    -------------------------------------------------------------------
     Package            /  Vulnerable  /                    Unaffected
    -------------------------------------------------------------------
  1  dev-db/phpmyadmin     < 2.11.5.2                      >= 2.11.5.2

Description
===========

Cezary Tomczak reported that an undefined UploadDir variable exposes an
information disclosure vulnerability when running on shared hosts.

Impact
======

A remote attacker with CREATE TABLE permissions can exploit this
vulnerability via a specially crafted HTTP POST request in order to
read arbitrary files.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All phpMyAdmin users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-db/phpmyadmin-2.11.5.2"

References
==========

  [ 1 ] CVE-2008-1924
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-1924

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200805-02.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2008 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.7 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFIH34RuhJ+ozIKI5gRApEYAJ46Qu3dq7DQJHXTaEJ6NtMmsbKaJQCgi8q1
y4VVfogC3jGPz0o5Ncw6qjA=
=exLu
-----END PGP SIGNATURE-----





Copyright © 1995-2019 LinuxRocket.net. All rights reserved.