[SECURITY] CVE-2013-2251: Apache Archiva Remote Command Execution

From: Brett Porter <brett@apache.org>
To: security@apache.org Team <security@apache.org>,full-disclosure@lists.grok.org.uk,bugtraq@securityfocus.com
Cc:
Subject: [SECURITY] CVE-2013-2251: Apache Archiva Remote Command Execution
Date:


CVE-2013-2251: Apache Archiva Remote Command Execution

Severity: Important

Vendor: The Apache Software Foundation

Versions Affected:
- Archiva 1.3 to Continuum 1.3.6
- The unsupported versions Archiva 1.2 to 1.2.2 are also affected.

Description:
Apache Archiva is affected by a vulnerability in the version of the Struts library being used, which allows a malicious user to run code on the server remotely. More details about the vulnerability can be found at http://struts.apache.org/2.3.x/docs/s2-016.html.

Mitigation:
All users are recommended to upgrade to Archiva 2.0.1 or Archiva 1.3.8, which are not affected by this issue.

Archiva 2.0.0 and later is not affected by this issue.

References:
http://archiva.apache.org/security.html








Copyright © 1995-2019 LinuxRocket.net. All rights reserved.