XSS in Canopy login page

From: RYT <me@ryantzj.com>
To: fulldisclosure@seclists.org,bugtraq@securityfocus.com
Cc:
Subject: XSS in Canopy login page
Date:


[Title]

XSS in Canopy login page

------------------------------------------

[Description]

CheckSec Canopy 3.x before 3.0.7 has stored XSS via the Login Page Disclaimer,

allowing attacks by low-privileged users against higher-privileged users.This

instance of stored cross-site scripting (XSS) vulnerability could

allow any users with administrator rights to inject malicious scripts

to compromise any users that visit the login page.

------------------------------------------

[Authors]

Wen Bin Kong (@kongwenbin) & @ryantzj

------------------------------------------

[CVSSv3 Score]

3.8

------------------------------------------

[CVSS Vector]

AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N

------------------------------------------

[Vulnerability Type]

Cross Site Scripting (XSS)

------------------------------------------

[Vendor of Product]

CheckSec Ltd

------------------------------------------

[Affected Product Code Base]

Canopy - 3.0.0-3.0.6

------------------------------------------

[Affected Component]

Login Page Disclaimer

------------------------------------------

[Attack Type]

Context-dependent

------------------------------------------

[CVE ID]

CVE-2018-9036

------------------------------------------

[Attack Vectors]

If a low privileged user were to enter a Cross-Site Scripting payload

into the Login Page Disclaimer, then when a user with higher

privileges browse the login page, the malicious content would be

executed within the latter's user context. The malicious payload could

also be configured to perform any application action available to the

authenticated user.

------------------------------------------

[Reference]

https://twitter.com/checksec

https://support.checksec.com/hc/en-us/articles/360000145163





Copyright © 1995-2018 LinuxRocket.net. All rights reserved.