[ GLSA 200807-03 ] PCRE: Buffer overflow

From: Robert Buchholz <rbu@gentoo.org>
To: gentoo-announce@gentoo.org
Cc: bugtraq@securityfocus.com,full-disclosure@lists.grok.org.uk,security-alerts@linuxsecurity.com
Subject: [ GLSA 200807-03 ] PCRE: Buffer overflow
Date:


- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200807-03
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: PCRE: Buffer overflow
      Date: July 07, 2008
      Bugs: #228091, #230039
        ID: 200807-03

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A buffer overflow vulnerability has been discovered in PCRE, allowing
for the execution of arbitrary code and a Denial of Service.

Background
==========

PCRE is a Perl-compatible regular expression library. GLib includes a
copy of PCRE.

Affected packages
=================

    -------------------------------------------------------------------
     Package           /   Vulnerable   /                   Unaffected
    -------------------------------------------------------------------
  1  dev-libs/libpcre       < 7.7-r1                         >= 7.7-r1
  2  dev-libs/glib         < 2.16.3-r1                    >= 2.16.3-r1
                                                              < 2.14.0
    -------------------------------------------------------------------
     2 affected packages on all of their supported architectures.
    -------------------------------------------------------------------

Description
===========

Tavis Ormandy of the Google Security team reported a heap-based buffer
overflow when compiling regular expression patterns containing
"Internal Option Settings" such as "(?i)".

Impact
======

A remote attacker could exploit this vulnerability by sending a
specially crafted regular expression to an application making use of
the PCRE library, which could possibly lead to the execution of
arbitrary code or a Denial of Service.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PCRE users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-libs/libpcre-7.7-r1"

All GLib users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-libs/glib-2.16.3-r1"

References
==========

  [ 1 ] CVE-2008-2371
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-2371

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200807-03.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2008 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5




Copyright © 1995-2019 LinuxRocket.net. All rights reserved.