[ANN] CVE-2018-11776 Apache Struts 2.3 to 2.3.34 and 2.5 to 2.5.16

From: Yasser Zamani <yasserzamani@apache.org>
To: Struts User <user@struts.apache.org>,Struts Dev <dev@struts.apache.org>,Struts Announcements <announcements@struts.apache.org>,Apache Announce <announce@apache.org>,security-reports@semmle.com <security-reports@semmle.com>,Struts Security <security@struts.apache.org>,oss-security <oss-security@lists.openwall.com>,full-disclosure <full-disclosure@lists.grok.org.uk>,bugtraq <bugtraq@securityfocus.com>
Cc:
Subject: [ANN] CVE-2018-11776 Apache Struts 2.3 to 2.3.34 and 2.5 to 2.5.16
Date:


[CVEID]:CVE-2018-11776
[PRODUCT]:Apache Struts
[VERSION]:Apache Struts 2.3 to 2.3.34 and 2.5 to 2.5.16
[PROBLEMTYPE]:Remote Code Execution
[REFERENCES]:https://cwiki.apache.org/confluence/display/WW/S2-057
[DESCRIPTION]:Man Yue Mo from the Semmle Security Research team was
noticed that Apache Struts versions 2.3 to 2.3.34 and 2.5 to 2.5.16
suffer from possible Remote Code Execution when using results with no
namespace and in same time, its upper action(s) have no or wildcard
namespace. Same possibility when using url tag which doesn\u2019t have value
and action set and in same time, its upper action(s) have no or wildcard
namespace.





Copyright © 1995-2018 LinuxRocket.net. All rights reserved.