[ GLSA 200901-10 ] GnuTLS: Certificate validation error

From: Pierre-Yves Rofes <py@gentoo.org>
To: gentoo-announce@gentoo.org
Cc: full-disclosure@lists.grok.org.uk,bugtraq@securityfocus.com,security-alerts@linuxsecurity.com
Subject: [ GLSA 200901-10 ] GnuTLS: Certificate validation error
Date:


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200901-10
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
~                                             http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

~   Severity: Normal
~      Title: GnuTLS: Certificate validation error
~       Date: January 14, 2009
~       Bugs: #245850
~         ID: 200901-10

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A certificate validation error in GnuTLS might allow for spoofing
attacks.

Background
==========

GnuTLS is an open-source implementation of TLS 1.0 and SSL 3.0.

Affected packages
=================

~     -------------------------------------------------------------------
~      Package          /  Vulnerable  /                      Unaffected
~     -------------------------------------------------------------------
~   1  net-libs/gnutls     < 2.4.1-r2                        >= 2.4.1-r2

Description
===========

Martin von Gagern reported that the _gnutls_x509_verify_certificate()
function in lib/x509/verify.c trusts certificate chains in which the
last certificate is an arbitrary trusted, self-signed certificate.

Impact
======

A remote attacker could exploit this vulnerability and spoof arbitrary
names to conduct Man-In-The-Middle attacks and intercept sensitive
information.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All GnuTLS users should upgrade to the latest version:

~     # emerge --sync
~     # emerge --ask --oneshot --verbose ">=net-libs/gnutls-2.4.1-r2"

References
==========

~   [ 1 ] CVE-2008-4989
~         http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-4989

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

~   http://security.gentoo.org/glsa/glsa-200901-10.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2009 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAklua+gACgkQuhJ+ozIKI5g1tgCeOEvV3MYts1IzizHmO2PMPtlo
jdcAn3Vv3VNJ2TKSHE0FyPS7hBrsIcdv
=ySwo
-----END PGP SIGNATURE-----





Copyright © 1995-2019 LinuxRocket.net. All rights reserved.